game:setValue(VGameObjectFont,"Fonts[my_font_name]")
game.GameObjectFont = Fonts["my_font_name"]
game.ObjectFont = Fonts.my_font_name
I'm not so keen on that method because it's not as clear. I like to separate the tables with . & access the visObj with ["this"] because it's much easier to spot what's what when you are scripting & something is incorrect or you need to change the name of the visOBJ you are accessing.game.ObjectFont = Fonts.my_font_name
would be even shorter.
game:setValue(VGameObjectFont,"Fonts[my_font_name]")
game.ObjectFont = Fonts.my_font_name